Back to overview
Degraded

Twilio LTE Network Degradation

May 05 at 01:15am PDT

Resolved
May 05 at 11:30am PDT

The root cause of the issue with Twilio has been resolved. Normal operations are now restored. Some chargers may be delayed in reconnecting as connectivity from Twilio's servers are restored.

Updated
May 05 at 06:16am PDT

We continue to see improvements in the stability of the Twilio network and are monitoring it for full resolution.

Updated
May 05 at 02:36am PDT

We are beginning to see recovery and stability on the Twilio Super SIM network. We will continue to monitor and update.

Created
May 05 at 01:15am PDT

Twilio Super SIM is currently experiencing degraded service that may impact roughly 5% of our network that operates on LTE connectivity. Chargers impacted will attempt to reconnect automatically but may drop again. Charging sessions already started will continue uninterrupted and will finish properly.