Back to overview
Degraded

Twilio LTE Network Degradation

Jun 29 at 01:12pm PDT
Affected services
Driver Experience

Resolved
Jun 30 at 07:30am PDT

All system issues are resolved and operating normally. Postmortem will follow.

Updated
Jun 30 at 06:50am PDT

We are still experiencing sporadic issues with chargers. We are observing some additional connectivity issues and are working to resolve them.

Updated
Jun 29 at 04:30pm PDT

We are still experiencing sporadic issues with chargers and are working to resolve the issue.

Updated
Jun 29 at 03:44pm PDT

Approximately 80% of chargers have recovered. Units that have not restored their connectivity will continue to attempt to reconnect.

Next update in 60 minutes or sooner.

Created
Jun 29 at 01:12pm PDT

Twilio Super SIM is currently experiencing degraded service. Chargers impacted will attempt to reconnect automatically but may drop again. Stations In use may show as UNAVAILABLE. Charging sessions already started will continue uninterrupted and will finish properly.